Hi, Second version of the RFC. The previous one is here: https://lore.kernel.org/linux-media/20210409133659.389544-1-tomi.valkeinen@xxxxxxxxxxxxxxxx/ In v2: - Rename v4l2_subdev_config -> v4l2_subdev_state - Rename pad_configs -> pads - Allocate the v4l2_subdev_state instead of embedding it I didn't: - Rename v4l2_subdev_pad_ops->init_cfg to init_state. There will be a huge amount of changes to drivers, and I'd like to keep any extra changes out of this series. For the same reason, I intend to keep the v4l2_subdev_state variable names as 'cfg' instead of trying to rename them to 'state'. - Add number of pads or a pointer to subdev to v4l2_subdev_state. It can be added easily if someone has a need for it. I also dropped the few driver changes I made. They are obvious trivial changes and don't really give anything to the discussion. Tomi Tomi Valkeinen (1): RFC: media: v4l2-subdev: add subdev-wide state struct drivers/media/v4l2-core/v4l2-subdev.c | 141 +++++++++++++++----------- include/media/v4l2-subdev.h | 72 +++++++------ 2 files changed, 120 insertions(+), 93 deletions(-) -- 2.25.1