On Thu, Jan 07, 2021 at 01:28:30PM +0000, Daniel Scally wrote: > OF, ACPI and software_nodes all implement graphs including nodes for ports > and endpoints. These are all intended to be named with a common schema, > as "port@n" and "endpoint@n" where n is an unsigned int representing the > index of the node. To ensure commonality across the subsystems, provide a > set of macros to define the format. > > Suggested-by: Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx> > Reviewed-by: Andy Shevchenko <andy.shevchenko@xxxxxxxxx> > Reviewed-by: Laurent Pinchart <laurent.pinchart@xxxxxxxxxxxxxxxx> > Signed-off-by: Daniel Scally <djrscally@xxxxxxxxx> Reviewed-by: Heikki Krogerus <heikki.krogerus@xxxxxxxxxxxxxxx> > --- > Changes in v5: > > - Changed commit subject > > include/linux/fwnode.h | 7 +++++++ > 1 file changed, 7 insertions(+) > > diff --git a/include/linux/fwnode.h b/include/linux/fwnode.h > index fde4ad97564c..77414e431e89 100644 > --- a/include/linux/fwnode.h > +++ b/include/linux/fwnode.h > @@ -50,6 +50,13 @@ struct fwnode_endpoint { > const struct fwnode_handle *local_fwnode; > }; > > +/* > + * ports and endpoints defined as software_nodes should all follow a common > + * naming scheme; use these macros to ensure commonality. > + */ > +#define SWNODE_GRAPH_PORT_NAME_FMT "port@%u" > +#define SWNODE_GRAPH_ENDPOINT_NAME_FMT "endpoint@%u" > + > #define NR_FWNODE_REFERENCE_ARGS 8 > > /** > -- > 2.25.1 -- heikki