On Thu, Oct 08, 2020 at 04:09:14PM +0200, Daniel Vetter wrote: > On Thu, Oct 08, 2020 at 01:23:40PM +0200, Christian König wrote: > > We have reoccurring requests on this so better document that > > this approach doesn't work and dma_buf_mmap() needs to be used instead. > > > > Signed-off-by: Christian König <christian.koenig@xxxxxxx> > > --- > > drivers/gpu/drm/drm_prime.c | 7 ++++++- > > 1 file changed, 6 insertions(+), 1 deletion(-) > > > > diff --git a/drivers/gpu/drm/drm_prime.c b/drivers/gpu/drm/drm_prime.c > > index 4910c446db83..16fa2bfc271e 100644 > > --- a/drivers/gpu/drm/drm_prime.c > > +++ b/drivers/gpu/drm/drm_prime.c > > @@ -956,7 +956,7 @@ EXPORT_SYMBOL(drm_gem_prime_import); > > /** > > * drm_prime_sg_to_page_addr_arrays - convert an sg table into a page array > > * @sgt: scatter-gather table to convert > > - * @pages: optional array of page pointers to store the page array in > > + * @pages: deprecated array of page pointers to store the page array in > > * @addrs: optional array to store the dma bus address of each page > > * @max_entries: size of both the passed-in arrays > > * > > @@ -965,6 +965,11 @@ EXPORT_SYMBOL(drm_gem_prime_import); > > * > > * Drivers can use this in their &drm_driver.gem_prime_import_sg_table > > * implementation. > > + * > > + * Specifying the pages array is deprecated and strongly discouraged for new > > + * drivers. The pages array is only useful for page faults and those can > > + * corrupt fields in the struct page if they are not handled by the exporting > > + * driver. > > */ > > I'd make this a _lot_ stronger: Aside from amdgpu and radeon all drivers > using this only need it for the pages array. Imo just open-code the sg > table walking loop in amdgpu/radeon (it's really not much code), and then > drop the dma_addr_t parameter from this function here (it's set to NULL by > everyone else). > > And then deprecate this entire function here with a big warning that a) > dma_buf_map_attachment is allowed to leave the struct page pointers NULL > and b) this breaks mmap, users must call dma_buf_mmap instead. > > Also maybe make it an uppercase DEPRECATED or something like that :-) OK I just realized I missed nouveau. That would be 3 places where we need to stuff the dma_addr_t list into something ttm can take. Still feels better than this half-deprecated function kludge ... -Daniel > -Daniel > > > int drm_prime_sg_to_page_addr_arrays(struct sg_table *sgt, struct page **pages, > > dma_addr_t *addrs, int max_entries) > > -- > > 2.17.1 > > > > -- > Daniel Vetter > Software Engineer, Intel Corporation > http://blog.ffwll.ch -- Daniel Vetter Software Engineer, Intel Corporation http://blog.ffwll.ch