On Mon, Nov 4, 2019 at 7:42 AM Laurent Pinchart <laurent.pinchart@xxxxxxxxxxxxxxxx> wrote: > > Hi Mani, > > (CC'ing Rob for a DT question at the end) > > On Fri, Nov 01, 2019 at 08:22:46PM +0530, Manivannan Sadhasivam wrote: > > Hi Laurent, > > > > Thanks for the improved version of the driver. I haven't tested it on > > my setup yet. Once I do, I'll add a Tested-by tag. > > > > I just have few minor commments on top of Sakari's review. Overall it > > looks good. > > > > On Thu, Oct 31, 2019 at 03:23:09PM +0200, Laurent Pinchart wrote: > > > The IMX296LLR is a monochrome 1.60MP CMOS sensor from Sony. The driver > > > supports cropping and binning (but not both at the same time due to > > > hardware limitations) and exposure, gain, vertical blanking and test > > > pattern controls. > > > > > > Preliminary support is also included for the color IMX296LQR sensor. > > > > > > Signed-off-by: Laurent Pinchart <laurent.pinchart@xxxxxxxxxxxxxxxx> > > > --- > > > + imx->reset = devm_gpiod_get_optional(&client->dev, "reset", > > > + GPIOD_OUT_HIGH); > > > + if (IS_ERR(imx->reset)) { > > > + if (PTR_ERR(imx->reset) != -EPROBE_DEFER) > > > + dev_err(&client->dev, "failed to get xclr gpio (%ld)\n", > > > > If you want to keep device specific naming for resources, I'd suggest using > > `xclr` instead of `reset` in DT itself. > > For GPIOs I think there's an overall consensus that standard names are > preferred, while I don't think this applies to clocks. It's a bit of a > grey area though, so I'm open to change on or the other. > > Rob, any preference ? If in fact that's a reset, then yes, use 'reset-gpios'. 'xclr' is an unusual name though. Rob