Re: [PATCH 1/2] dvbsky: add support for "Mygica T230C v2"

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 





On 7/8/19 12:04 PM, Sean Young wrote:
Hallo Jan-Pieter,

On 6/25/19 1:16 PM, Sean Young wrote:
On Sun, Jun 16, 2019 at 02:39:29AM +0200, Jan Pieter van Woerkom wrote:
From: Jan Pieter van Woerkom <jp@xxxxxxx>

Adds support for the "Mygica T230C v2" into the "dvbsky" driver.
A small enhancement is also needed in the si2168 demodulator
driver, and a USB device ID in dvb-usb-ids.h .

This is v3.3 of the proposed patch, based on feedback from Sean
Young and Antti Palosaari.
Tested by patch author on a T230C v2.
Tested by Frank Rysanek on a T230C v2: can tune into locally
available DVB-T and DVB-T2 muxes, video and audio playback works.
Applies cleanly against Linux 5.1.10 .

The T230C v2 hardware needs a mode of the si2168 chip to be
set for which the si2168 driver previously had no support.
This patch uses a specific measure to configure this on the
T230C v2 hardware only - see the flag passed via the ts_mode
attribute and its dependency on USB_PID_MYGICA_T230C2. Other
devices using the si2168 demodulator driver are not affected
in any way.

Signed-off-by: Jan Pieter van Woerkom <jp@xxxxxxx>
Tested-by: Frank Rysanek <Frantisek.Rysanek@xxxxxxx>
---
diff -ru a/drivers/media/dvb-frontends/si2168.c b/drivers/media/dvb-frontends/si2168.c
--- a/drivers/media/dvb-frontends/si2168.c	2019-06-04 07:59:45.000000000 +0200
+++ b/drivers/media/dvb-frontends/si2168.c	2019-06-08 19:47:32.385526558 +0200
@@ -91,8 +91,18 @@
   	dev_dbg(&client->dev, "%s acquire: %d\n", __func__, acquire);
+	/* set manual value */
+	if (dev->ts_mode | SI2168_TS_CLK_MANUAL) {
This looks wrong. Should it not be "dev->ts_mode & SI2168_TS_CLK_MANUAL"?
Now the expression is always true.
You're absolutely right. Silly me.

What now? Correct and repost?
Yes, please. I don't have the hardware to test so it would be great if
you could repost a tested version, so we can merged that.
Done,  sent as new post to the linux-media list. I messed up one
subject line, 2/1 instead of 1/2.

Also, I made a another change (as per Antti's recommendation):
instead of piggybacking the magic value on the ts_mode variable,
define own boolean flag and use that when this special si2168
mode is needed.

Thanks,

Sean

Thank you,

Jan Pieter



[Index of Archives]     [Linux Input]     [Video for Linux]     [Gstreamer Embedded]     [Mplayer Users]     [Linux USB Devel]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [Yosemite Backpacking]

  Powered by Linux