On 6/12/19 10:12 AM, Anders Roxell wrote: > When building with CONFIG_VIDEO_ADV7511 and CONFIG_DRM_I2C_ADV7511 > enabled as loadable modules, we see the following warning: > > warning: same module names found: > drivers/gpu/drm/bridge/adv7511/adv7511.ko > drivers/media/i2c/adv7511.ko > > Rework so the names matches the config fragment. > > Signed-off-by: Anders Roxell <anders.roxell@xxxxxxxxxx> > --- > drivers/media/i2c/Makefile | 3 ++- > 1 file changed, 2 insertions(+), 1 deletion(-) > > diff --git a/drivers/media/i2c/Makefile b/drivers/media/i2c/Makefile > index d8ad9dad495d..b71a427a89fd 100644 > --- a/drivers/media/i2c/Makefile > +++ b/drivers/media/i2c/Makefile > @@ -35,7 +35,8 @@ obj-$(CONFIG_VIDEO_ADV748X) += adv748x/ > obj-$(CONFIG_VIDEO_ADV7604) += adv7604.o > obj-$(CONFIG_VIDEO_ADV7842) += adv7842.o > obj-$(CONFIG_VIDEO_AD9389B) += ad9389b.o > -obj-$(CONFIG_VIDEO_ADV7511) += adv7511.o > +obj-$(CONFIG_VIDEO_ADV7511) += video-adv7511.o > +video-adv7511-objs := adv7511.o I prefer adv7511-v4l2 as the new name. 'video' is too vague and can easily be confused with drivers/video. I think it is better to rename adv7511.c to adv7511-v4l2.c and add a comment at the top of that source explaining why it is named like that. Regards, Hans > obj-$(CONFIG_VIDEO_VPX3220) += vpx3220.o > obj-$(CONFIG_VIDEO_VS6624) += vs6624.o > obj-$(CONFIG_VIDEO_BT819) += bt819.o >