Re: [RFCv4 PATCH 0/3] This RFC patch series implements properties for the media controller.

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi Hans,

Em Wed, 21 Nov 2018 16:40:21 +0100
Hans Verkuil <hverkuil@xxxxxxxxx> escreveu:

> The main changes since RFCv3 are:
> 
> - Add entity index to media_v2_pad
> - Add source/sink pad index to media_v2_link
> - Add owner_idx and owner type flags to media_v2_prop

Sorry, but I didn't get why this is needed for properties to work
(if the changes are not directly related to properties, please add
on separate patches, in order to make easier for review/understanding).

The lack of an uAPI documentation at the patchset makes it harder
to understand.

For the last one, you added a documentation at kAPI:

> + * @owner_idx:	Index to entities/pads/properties, depending on the owner ID
> + *		type.

But it doesn't really explain anything. Is it the new owner_id
field? Is it something else? Why do we need bot owner_id and 
owner_idx?

> 
> An updated v4l2-ctl and v4l2-compliance that can report properties
> is available here:
> 
> https://git.linuxtv.org/hverkuil/v4l-utils.git/log/?h=props
> 
> Currently I support u64, s64 and const char * property types. And also
> a 'group' type that groups sub-properties. But it can be extended to any
> type including binary data if needed. No array support (as we have for
> controls), but there are enough reserved fields in media_v2_prop
> to add this if needed.
> 
> I added properties for entities and pads to vimc, so I could test this.
> 
> Note that the changes to media_device_get_topology() are hard to read
> from the patch. It is easier to just look at the source code:
> 
> https://git.linuxtv.org/hverkuil/media_tree.git/tree/drivers/media/media-device.c?h=mc-props
> 
> I have some ideas to improve this some more:
> 
> 1) Add the properties directly to media_gobj. This would simplify some
>    of the code, but it would require a media_gobj_init function to
>    initialize the property list. In general I am a bit unhappy about
>    media_gobj_create: it doesn't really create the graph object, instead
>    it just adds it to the media_device. It's confusing and it is something
>    I would like to change.
> 
> 2) The links between pads are stored in media_entity instead of in media_pad.
>    This is a bit unexpected and makes it harder to traverse the data
>    structures since to find the links for a pad you need to walk the entity
>    links and find the links for that pad. Putting all links in the entity
>    also mixes up pad and interface links, and it would be much cleaner if
>    those are separated.
> 
> 3) I still think adding support for backlinks to G_TOPOLOGY is a good idea.
>    Since the current data structure represents a flattened tree that is easy
>    to navigate the only thing missing for userspace is backlink support.
>    This is still something that userspace needs to figure out when the kernel
>    has this readily available. I think that with this in place applications
>    can just do all the lookups directly on the topology data structure.

Apps don't need to follow the exact data struct model as the Kernel,
and can dynamically create any indexes they need in order to quickly
seek for a link (if search performance would be a problem).

I don't like the idea of reporting all links twice to userspace. 
Specially after Spectre/Meltdown, context switches are expensive.

Duplicating data is a very bad idea, as it will enforce an specific
data model at the application and at userspace. We want to be able
to change the internals (on both sides) if needed for whatever
reason. 

Also, what happens if the duplicated information is not really
the same (that could happen due to a bug somewhere)? Should
apps validate it? Worse than that, if we report the same link
twice (on both directions), userspace will send link changes
at the backlinks, making the Kernel code more complex (and
bound forever to an specific implementation) for no good reason.

> 
> 1+2 are internal cleanups that can be done later.
> 
> 3 is a low-priority future enhancement. This might become easier to implement
> once 1+2 are done.
> 
> This is pretty much the last RFC. If everyone agree with this approach, then
> I can make a final patch series, adding documentation etc.
> 
> Regards,
> 
>         Hans
> 
> 
> Hans Verkuil (3):
>   uapi/linux/media.h: add property support
>   media controller: add properties support
>   vimc: add property test code
> 
>  drivers/media/media-device.c              | 335 +++++++++++++++++-----
>  drivers/media/media-entity.c              | 107 ++++++-
>  drivers/media/platform/vimc/vimc-common.c |  50 ++++
>  include/media/media-device.h              |   6 +
>  include/media/media-entity.h              | 318 ++++++++++++++++++++
>  include/uapi/linux/media.h                |  88 +++++-
>  6 files changed, 819 insertions(+), 85 deletions(-)
> 



Thanks,
Mauro



[Index of Archives]     [Linux Input]     [Video for Linux]     [Gstreamer Embedded]     [Mplayer Users]     [Linux USB Devel]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [Yosemite Backpacking]

  Powered by Linux