On 07/03/18 23:04, Niklas Söderlund wrote: > In preparation for Gen3 support move the subdevice initialization and > clean up from rvin_v4l2_{register,unregister}() directly to the async > callbacks. This simplifies the addition of Gen3 support as the > rvin_v4l2_register() can be shared for both Gen2 and Gen3 while direct > subdevice control are only used on Gen2. > > While moving this code drop a large comment which is copied from the > framework documentation and fold rvin_mbus_supported() into its only > caller. Also move the initialization and cleanup code to separate > functions to increase readability. > > Signed-off-by: Niklas Söderlund <niklas.soderlund+renesas@xxxxxxxxxxxx> > Reviewed-by: Laurent Pinchart <laurent.pinchart@xxxxxxxxxxxxxxxx> > --- > drivers/media/platform/rcar-vin/rcar-core.c | 108 +++++++++++++++++++--------- > drivers/media/platform/rcar-vin/rcar-v4l2.c | 35 --------- > 2 files changed, 74 insertions(+), 69 deletions(-) > > diff --git a/drivers/media/platform/rcar-vin/rcar-core.c b/drivers/media/platform/rcar-vin/rcar-core.c > index 47f06acde2e698f2..663309ca9c04f208 100644 > --- a/drivers/media/platform/rcar-vin/rcar-core.c > +++ b/drivers/media/platform/rcar-vin/rcar-core.c > @@ -46,46 +46,88 @@ static int rvin_find_pad(struct v4l2_subdev *sd, int direction) > return -EINVAL; > } > > -static bool rvin_mbus_supported(struct rvin_graph_entity *entity) > +/* The vin lock shuld be held when calling the subdevice attach and detach */ shuld -> should Actually, I'd say 'shall' instead of 'should'. After that trivial change you can add my: Reviewed-by: Hans Verkuil <hans.verkuil@xxxxxxxxx> Regards, Hans