On Sun, 01 Nov 2009 00:13:10 +0100 Németh Márton <nm127@xxxxxxxxxxx> wrote: > the following patchset refactores the Pixart PAC7311 subdriver. The > current situation is that the code contains a lot of decisions > like this: > > if (sd->sensor == SENSOR_PAC7302) { > ... do this ... > } else { > ... do something else ... > } > > The sensor type is determined using the USB Vendor ID and Product > ID which means that the decisions shown are not really necessary. > > The goal of the patchset is to have a PAC7302 and a PAC7311 subdriver > which have the benefit that there is no decision necessary on sensor > type at runtime. The common functions can be extracted later but this > would be a different patchset. Hello Márton, Splitting the pac7311 subdriver is a good idea, but I don't like your patchset: a lot of changes (function prefixes) are nullified by the last patch. I'd better like only one change for the pac7302 creation and a second one for the interface change of pac_find_sof() in pac_common.h (BTW, this file could now be compiled separately). Regards. -- Ken ar c'hentañ | ** Breizh ha Linux atav! ** Jef | http://moinejf.free.fr/ -- To unsubscribe from this list: send the line "unsubscribe linux-media" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html