>> @@ -1091,7 +1091,7 @@ static int vpfe_enum_input(struct file *file, void *priv, >> return -EINVAL; >> } >> sdinfo = &vpfe_dev->cfg->sub_devs[subdev]; >> - memcpy(inp, &sdinfo->inputs[index], sizeof(struct v4l2_input)); >> + memcpy(inp, &sdinfo->inputs[index], sizeof(*inp)); > > If I am not mistaken this can be written as: > > *inp = sdinfo->inputs[index]; > > Much better. At which position would you like to integrate a second approach for such a change from this patch series? * Do you expect me to send a "V2" for the whole series? * Will an update step be appropriate if I would rebase it on other recently accepted suggestions? Regards, Markus -- To unsubscribe from this list: send the line "unsubscribe linux-media" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html