Hi, I missed the original mail, so I am replying to this one. See below. >> @@ -375,6 +384,29 @@ >> struct dvb_demux_feed *feed; >> u16 pid = ts_pid(buf); >> int dvr_done = 0; >> + > > No need for an empty line here. Please remove to keep all vars together. > >> + int cnt_pid; > > unsigned cnt_pid; > There's no need for "cnt_pid" at all, because "pid" already contains the PID value. > Please add a define for 0x1fff and use the define, instead of using a magic value at vmalloc, like: > > #define MAX_PID 0x1ffe One would assume MAX_PID to be 0x1fff. Maybe it would be better to have two definitions to improve readability. for dvb_dmx_swfilter_packet(): #define NULL_PID 0x1fff for vmalloc: #define MAX_PID 0x1fff or #define NUM_PIDS 0x2000 ... and use (NUM_PIDS - 1) to make clear that no memory for the NULL PID is allocated. Regards, Andreas -- To unsubscribe from this list: send the line "unsubscribe linux-media" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html