On Tue, Oct 31, 2023 at 2:23 PM Alejandro Colomar <alx@xxxxxxxxxx> wrote: > > Hi Elliott, > > On Tue, Oct 31, 2023 at 12:15:43PM -0700, enh wrote: > > "operation" is certainly the most general, and i struggle to see any > > value to the current wording --- it's not like any of them help the > > reader know "what goes here" without accompanying documentation. > > > > TL;DR: "yeah, if you change the man pages, i'll definitely change > > Android's headers to simplify them in this way" (and i have no > > I'll do it; will CC you on any such changes. fwiw, here's the full list of "cmd"s, "request"s, "op"s, and "option"s (manually edited to remove the legit "option"s like getsockopt()): ~/aosp-main-with-phones/bionic/libc/include$ egrep -r '__(cmd|option|request|op)\b' | sort bits/fcntl.h:int fcntl(int __fd, int __cmd, ...); bits/ioctl.h:int ioctl(int __fd, int __request, ...); bits/lockf.h:int lockf(int __fd, int __cmd, off_t __length) __RENAME_IF_FILE_OFFSET64(lockf64) __INTRODUCED_IN(24); sys/epoll.h:int epoll_ctl(int __epoll_fd, int __op, int __fd, struct epoll_event* __BIONIC_COMPLICATED_NULLNESS __event); sys/file.h:int flock(int __fd, int __op); syslog.h:void openlog(const char* _Nullable __prefix, int __option, int __facility); sys/msg.h:int msgctl(int __msg_id, int __cmd, struct msqid_ds* _Nullable __buf) __INTRODUCED_IN(26); sys/prctl.h:int prctl(int __option, ...); sys/ptrace.h:long ptrace(int __request, ...); sys/quota.h:int quotactl(int __cmd, const char* _Nullable __special, int __id, char* __BIONIC_COMPLICATED_NULLNESS __addr) __INTRODUCED_IN(26); sys/reboot.h:int reboot(int __cmd); sys/sem.h:int semctl(int __sem_id, int __sem_num, int __cmd, ...) __INTRODUCED_IN(26); sys/shm.h:int shmctl(int __shm_id, int __cmd, struct shmid_ds* _Nullable __buf) __INTRODUCED_IN(26); time.h:int clock_nanosleep(clockid_t __clock, int __flags, const struct timespec* _Nonnull __request, struct timespec* _Nullable __remainder); time.h:int nanosleep(const struct timespec* _Nonnull __request, struct timespec* _Nullable __remainder); ~/aosp-main-with-phones/bionic/libc/include$ (i'll change the <time.h> *sleep()s to use __duration instead: https://android-review.googlesource.com/c/platform/bionic/+/2813844) > Cheers, > Alex > > > particular opinion about _which_ word, and that sounds like a bikeshed > > it's not worth going near :-) ). > > -- > <https://www.alejandro-colomar.es/>