Quoting Michael Kerrisk (man-pages) (mtk.manpages@xxxxxxxxx): > On 12/16/2016 01:44 AM, Casey Schaufler wrote: > > On 12/15/2016 4:31 PM, John Stultz wrote: > >> On Thu, Dec 15, 2016 at 12:40 PM, Casey Schaufler > >> <casey@xxxxxxxxxxxxxxxx> wrote: > >>> On 12/15/2016 11:41 AM, Michael Kerrisk (man-pages) wrote: > >>>> On 12/15/2016 05:29 PM, Casey Schaufler wrote: > >>>>> CAP_WAKE_ALARM could readily be CAP_TIME. > >>>> Actually, I don't quite understand what you mean with that sentence. > >>>> Could you elaborate? > >>> Should have said CAP_SYS_TIME > >>> > >>> Setting an alarm could be considered a time management function, > >>> depending on what it actually does. > >> Just a nit here. CAP_WAKE_ALARM is more about the privilege of waking > >> a system from suspend, while CAP_SYS_TIME covers the ability to set > >> the time. One wouldn't necessarily want to give applications which > >> could wake a system up the capability to also set the time. > > > > Doesn't really matter, except that an ignorant developer > > might make the mistake I did and assume that WAKE_ALARM > > was somehow related to time management. If you want to use > > it as an example don't let my dunderheadedness get in your > > way. > > Actually, I decided it wasn't such a good example anyway. > That capability could potentially be generic. (But it probably > should better have been named something like 'CAP_WAKE_SYSTEM'.) How about: Subject: [PATCH 1/1] capabilities: alias CAP_WAKE_SYSTEM to CAP_WAKE_ALARM As suggested by Michael Kerrisk his is a less confusing name, and this won't break any old userspace. Signed-off-by: Serge Hallyn <serge@xxxxxxxxxx> Cc: Michael Kerrisk <mtk.manpages@xxxxxxxxx> --- include/uapi/linux/capability.h | 2 ++ 1 file changed, 2 insertions(+) diff --git a/include/uapi/linux/capability.h b/include/uapi/linux/capability.h index fd4f87d..ba972ff 100644 --- a/include/uapi/linux/capability.h +++ b/include/uapi/linux/capability.h @@ -357,6 +357,8 @@ struct vfs_ns_cap_data { #define CAP_WAKE_ALARM 35 +#define CAP_WAKE_SYSTEM CAP_WAKE_ALARM + /* Allow preventing system suspends */ #define CAP_BLOCK_SUSPEND 36 -- 2.7.4 -- To unsubscribe from this list: send the line "unsubscribe linux-man" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html