Re: [PATCH 3/5] m68k: m5441x: add flexcan support

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi Angelo,

On 10/6/21 5:59 pm, Angelo Dureghello wrote:
Hi Greg,

On 09/06/21 3:24 PM, Greg Ungerer wrote:
Hi Angelo,

On 9/6/21 6:45 am, Angelo Dureghello wrote:
Add flexcan support.

Signed-off-by: Angelo Dureghello <angelo@xxxxxxxxxxxxxxxx>
---
  arch/m68k/coldfire/device.c       | 31 +++++++++++++++++++++++++++++++
  arch/m68k/coldfire/m5441x.c       |  8 ++++----
  arch/m68k/include/asm/m5441xsim.h | 19 +++++++++++++++++++
  3 files changed, 54 insertions(+), 4 deletions(-)


diff --git a/arch/m68k/coldfire/m5441x.c b/arch/m68k/coldfire/m5441x.c
index 1e5259a652d1..18b152edb69c 100644
--- a/arch/m68k/coldfire/m5441x.c
+++ b/arch/m68k/coldfire/m5441x.c
@@ -18,8 +18,8 @@
  #include <asm/mcfclk.h>
  DEFINE_CLK(0, "flexbus", 2, MCF_CLK);
-DEFINE_CLK(0, "mcfcan.0", 8, MCF_CLK);
-DEFINE_CLK(0, "mcfcan.1", 9, MCF_CLK);
+DEFINE_CLK(0, "flexcan.0", 8, MCF_CLK);
+DEFINE_CLK(0, "flexcan.1", 9, MCF_CLK);
  DEFINE_CLK(0, "imx1-i2c.1", 14, MCF_CLK);

Just a heads up, but this will likely conflict with Arnd's clock changes, see:

     https://lkml.org/lkml/2021/6/8/774


is this a clock naming issue ? The "mcfcan" is actually
not referenced in any driver so naming it "flexcan"
shouldn't be an issue.

Yeah, no problem with that. The "mcfcan" name was really just a
place holder here. Not used previously.

My comment is more that your patches and Anrd's are touching
some of the same things. Depending on whose is applied first one
or the other will need to be updated to reflect the others.
No big deal, and easy to do in this case.

Regards
Greg



Or i should get and enable "mcfcan" clock from the driver ?

Regards
Greg


Thanks,
regards,



[Index of Archives]     [Video for Linux]     [Yosemite News]     [Linux S/390]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux