On Sun, Dec 27, 2020 at 03:01:28PM +0100, Enrico Weigelt, metux IT consult wrote:
Move the pm_power_off callback into one global place and also add an function for conditionally calling it (when not NULL), in order to remove code duplication in all individual archs. Reported-by: kernel test robot <lkp@xxxxxxxxx> Signed-off-by: Enrico Weigelt, metux IT consult <info@xxxxxxxxx>
[...]
diff --git a/kernel/reboot.c b/kernel/reboot.c index eb1b15850761..ec4cd66dd1ae 100644 --- a/kernel/reboot.c +++ b/kernel/reboot.c @@ -53,6 +53,16 @@ int reboot_force; void (*pm_power_off_prepare)(void); EXPORT_SYMBOL_GPL(pm_power_off_prepare); +void (*pm_power_off)(void); +EXPORT_SYMBOL_GPL(pm_power_off); + +void do_power_off(void) +{ + if (pm_power_off) + pm_power_off(); +} +EXPORT_SYMBOL_GPL(do_power_off);
Could this just live as a static inline in pm.h to avoid having to export the extra symbol? Will