On Fri, 23 Oct 2020 at 22:03, Linus Torvalds
<torvalds@xxxxxxxxxxxxxxxxxxxx> wrote:
On Fri, Oct 23, 2020 at 8:54 AM Linus Torvalds
<torvalds@xxxxxxxxxxxxxxxxxxxx> wrote:
On Fri, Oct 23, 2020 at 12:14 AM Rasmus Villemoes
<linux@xxxxxxxxxxxxxxxxxx> wrote:
That's certainly garbage. Now, I don't know if it's a sufficient fix (or
could break something else), but the obvious first step of rearranging
so that the ptr argument is evaluated before the assignment to __val_pu
Ack. We could do that.
I'm more inclined to just bite the bullet and go back to the ugly
conditional on the size that I had hoped to avoid, but if that turns
out too ugly, mind signing off on your patch and I'll have that as a
fallback?
Actually, looking at that code, and the fact that we've used the
"register asm()" format forever for the get_user() side, I think your
approach is the right one.
I'd rename the internal ptr variable to "__ptr_pu", and make sure the
assignments happen just before the asm call (with the __val_pu
assignment being the final thing).
lso, it needs to be
void __user *__ptr_pu;
instead of
__typeof__(ptr) __ptr = (ptr);
because "ptr" may actually be an array, and we need to have the usual
C "array to pointer" conversions happen, rather than try to make
__ptr_pu be an array too.
So the patch would become something like the appended instead, but I'd
still like your sign-off (and I'd put you as author of the fix).
Narest, can you confirm that this patch fixes the issue for you?
This patch fixed the reported problem.
Tested-by: Naresh Kamboju <naresh.kamboju@xxxxxxxxxx>
Build location:
https://builds.tuxbuild.com/uDAiW8jkN61oWoyxZDkEYA/
Test logs,
https://lkft.validation.linaro.org/scheduler/job/1868045#L1597
- Naresh