On Wed, Aug 14, 2019 at 10:28 AM Linus Walleij <linus.walleij@xxxxxxxxxx> wrote:
On Mon, Aug 12, 2019 at 9:30 AM Geert Uytterhoeven <geert@xxxxxxxxxxxxxx> wrote:
When test-compiling the BCM2835 pin control driver on m68k:
In file included from arch/m68k/include/asm/io_mm.h:32:0,
from arch/m68k/include/asm/io.h:8,
from include/linux/io.h:13,
from include/linux/irq.h:20,
from include/linux/gpio/driver.h:7,
from drivers/pinctrl/bcm/pinctrl-bcm2835.c:17:
drivers/pinctrl/bcm/pinctrl-bcm2835.c: In function 'bcm2711_pull_config_set':
arch/m68k/include/asm/atarihw.h:190:22: error: expected identifier or '(' before 'volatile'
# define shifter ((*(volatile struct SHIFTER *)SHF_BAS))
"shifter" is a too generic name for a global definition.
As the corresponding definition for Atari TT is already called
"shifter_tt", fix this by renaming the definition for Atari ST to
"shifter_st".
Reported-by: kbuild test robot <lkp@xxxxxxxxx>
Suggested-by: Michael Schmitz <schmitzmic@xxxxxxxxx>
Signed-off-by: Geert Uytterhoeven <geert@xxxxxxxxxxxxxx>
Finally we can use the sh pfc pin controller on our m68k Atari.
Now if I can only resolder the capacitors on my Atari TT ST
before the board self-destructs I will one day test this.
Reviewed-by: Linus Walleij <linus.walleij@xxxxxxxxxx>
Thanks, applied and queued for v5.4.
Gr{oetje,eeting}s,
Geert
--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@xxxxxxxxxxxxxx
In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
-- Linus Torvalds