On Mon, Apr 23, 2012 at 15:50, Ezequiel Garcia <elezegarcia@xxxxxxxxx> wrote:
Signed-off-by: Ezequiel Garcia <elezegarcia@xxxxxxxxx> --- To define or to inline that is the question: The current definition of flat_set_persistent produces a compiler warning; arch/sh/ does it in a different way defining it to a macro that uses persistent var. IMHO, an inline is easier to read.
What's the compiler warning? It seems several other nommu arches use the same definition for flat_set_persistent()?
--- arch/m68k/include/asm/flat.h | 7 ++++++- 1 files changed, 6 insertions(+), 1 deletions(-) diff --git a/arch/m68k/include/asm/flat.h b/arch/m68k/include/asm/flat.h index a0e2907..f9454b8 100644 --- a/arch/m68k/include/asm/flat.h +++ b/arch/m68k/include/asm/flat.h @@ -11,6 +11,11 @@ #define flat_get_addr_from_rp(rp, relval, flags, p) get_unaligned(rp) #define flat_put_addr_at_rp(rp, val, relval) put_unaligned(val,rp) #define flat_get_relocate_addr(rel) (rel) -#define flat_set_persistent(relval, p) 0 + +static inline int flat_set_persistent(unsigned long relval, + unsigned long *persistent) +{ + return 0; +} #endif /* __M68KNOMMU_FLAT_H__ */ -- 1.7.3.4
Gr{oetje,eeting}s, Geert -- Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@xxxxxxxxxxxxxx In personal conversations with technical people, I call myself a hacker. But when I'm talking to journalists I just say "programmer" or something like that. -- Linus Torvalds -- To unsubscribe from this list: send the line "unsubscribe linux-m68k" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html