On Fri, 2010-04-16 at 12:34 +1000, Finn Thain wrote:
...but this one was already merged, unfortunately.
Use printk_once
Add #define pr_fmt(fmt) KBUILD_MODNAME ": " fmt
Convert printks without KERN_<level> to pr_info and pr_cont
Signed-off-by: Joe Perches <joe@xxxxxxxxxxx>
Signed-off-by: David S. Miller <davem@xxxxxxxxxxxxx>
diff --git a/drivers/net/mac8390.c b/drivers/net/mac8390.c
index 517cee4..8bd09e2 100644 (file)
--- a/drivers/net/mac8390.c
+++ b/drivers/net/mac8390.c
@@ -17,6 +17,8 @@
/* 2002-12-30: Try to support more cards, some clues from NetBSD driver */
/* 2003-12-26: Make sure Asante cards always work. */
+#define pr_fmt(fmt) KBUILD_MODNAME ": " fmt
+
Why the macro? You only used it once.
It's used embedded in the pr_<level> functions.
It's used more than once.
The pr_xxx naming convention belongs to a kernel-wide include file. Is it
really a good idea to start repurposing it in .c files?
It's in kernel.h, and yes, it is.
http://lkml.org/lkml/2008/11/12/297
No, this is pr_err. The driver sets dev->mem_start expecting it to work,
obviously.
I suggest you change the levels to what you desire.
You could add yourself to the MAINTAINERS entry for this file.
cheers, Joe
--
To unsubscribe from this list: send the line "unsubscribe linux-m68k" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html