Hi,
Issues:
1. When Atari support is enabled, `scc' is defined in
include/asm-m68k/atari.h as:
# define scc ((*(volatile struct SCC*)SCC_BAS))
This can be renamed - it is only used for control and data port address init
(aside from serial console, which should probably be separated out if it cannot
be reconciled).
However, renaming the variable `scc' doesn't help, as
2. the variable `scc' is not used in scc_carrier_raised(),
3. `port->channel' on line 635 still fails as `port' is not longer `struct
scc_port', but a 'struct tty_port', which has no member named 'channel'.
Will take a look at this, but gs is going to away so at some point
someone with hardware is going to have to admit to owning this driver or
just mark it BROKEN..
Time to merge with pmac_zilog or ip22zilog (the latter even needing similar
register access delays as Ataris).
What is the time frame to gs being removed? I admit to 'owning' atari_scc which
was based on vme_scc so I'll have to deal with that sooner or later.
Michael
--
To unsubscribe from this list: send the line "unsubscribe linux-m68k" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html