On Wed, Oct 24 2007, Geert Uytterhoeven wrote:
On Wed, 24 Oct 2007, Jens Axboe wrote:
On Tue, Oct 23 2007, Linus Torvalds wrote:
My biggest complaint right now is that a lot of users of the sg *filling*
functions were mindlessly converted, so we have code like
cryptoloop.c: sg_set_page(&sg_in, in_page);
cryptoloop.c: sg_in.offset = in_offs;
cryptoloop.c: sg_in.length = sz;
which is just really stupid, and we should have a function for that. But
worse is code like this:
ub.c: sg_set_page(sg, virt_to_page(sc->top_sense));
ub.c: sg->offset = (unsigned long)sc->top_sense & (PAGE_SIZE-1);
ub.c: sg->length = UB_SENSE_SIZE;
which again was converted "line by line" and we actually *do* have a
function to do the above three lines as
sg_set_buf(sg, sc->top_sense, UB_SENSE_SIZE);
where that *single* line is just tons shorter but more importantly, more
readable, than the mess that is a brute-force conversion.
I modified sg_set_page() to take a length and offset argument, and
As it no longer sets the page only, perhaps it's a good idea to rename
sg_set_page() to sg_set()?
sg_set_buf() also sets length and offset, sg_set_page() is just a mirror
of that. So I'd prefer to keep the naming.
--
Jens Axboe
-
To unsubscribe from this list: send the line "unsubscribe linux-m68k" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html