Re: [PATCH/RFC 0/2] Zorro modalias support

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



What do you think?

We would need something like that anyway, in order to convert drivers to
the new generic driver model, if I understand it right (the only driver

The alternative is to keep (convert to, for some) them as platform
devices. But that means no auto-load based on modalias.

Right - platform device was the name I keep forgetting ....

Re: bus type - multiplatform support is all dead anyway so we could
instead call it 'host' or 'm68k' and collect all on-board stuff there. And

I prefer to call it by the platform name, though (see below).

I count Nubus/Zorro as on-board here. Just keeping in mind how I got my
BUS_ATARI in the input patch shot down.

But we do have BUS_ATARI in <linux/input.h> now ;-)

I was planning on removing that again ... thought it got vetoed.

Am I mixing things up?

I think so...

Nubus and Zorro are definitely separate buses, as they support automatic
probing.

Most other `system bus' hardware doesn't have to be probed (in the ISA
bang-a-few-ports-and-we'll-see sense) on m68k. We use
{amiga,atari,mac}_hw_present to find out if something exists.

OK; so host/m68k/system/onboard/whatever, nubus and zorro should be
sufficient.


So we could easily have in arch/*/config.c:

    if ({AMIGA,ATARI,MAC}HW_PRESENT(XXX))
	register_XXX_device();
    if ({AMIGA,ATARI,MAC}HW_PRESENT(YYY))
	register_YYY_device();
    ...

For XXX, YYY = GRAPHICS, KEYBOARD, BUILTIN_SCSI, ...
and we have our `system bus'. Devices could be numbered just starting from
1 (or use the {amiga,atari,mac}_hw_present numbers? But we don't need
devices for all of them, at least on Amiga), as we control what's there

Is the plan to move any or all of these to the platfoem driver or later
code at all?

anyway. Module alias would then be of the form `{amiga,atari,mac}:%u'.
See why I don't want to call it `host' or `m68k'?
Hmm, maybe we should call it `host' or `m68k', to make it even more generic
and use `host:{amiga,atari,mac}%u' for module aliases? One day other
platforms may want to start using it, too...

A `git grep 'struct bus_type.*= {' definitely shows a few `system
buses'. It's even used for SoCs, which is in some sense very similar to
Amiga, Atari, and Mac (it's just that VLSI wasn't sufficiently advanced in the
eighties to give us single-chip solutions).

OK, needs more thought before deciding on a name I guess.

	Michael
-
To unsubscribe from this list: send the line "unsubscribe linux-m68k" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html

[Index of Archives]     [Video for Linux]     [Yosemite News]     [Linux S/390]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux