On Wed, 16 Aug 2023, Justin Stitt wrote: > When building with clang 18 I see the following warning: > | drivers/leds/leds-pca955x.c:487:15: warning: cast to smaller integer > | type 'enum pca955x_type' from 'const void *' [-Wvoid-pointer-to-enum-cast] > | 487 | chip_type = (enum pca955x_type)md; > > This is due to the fact that `md` is a void* while `enum pca995x_type` has the > size of an int. > > Add uintptr_t cast to silence clang warning while also keeping enum cast > for readability and consistency with other `chip_type` assignment just a > few lines below: > | chip_type = (enum pca955x_type)id->driver_data; > > Link: https://github.com/ClangBuiltLinux/linux/issues/1910 > Reported-by: Nathan Chancellor <nathan@xxxxxxxxxx> A review from Nathan would be good here. > Signed-off-by: Justin Stitt <justinstitt@xxxxxxxxxx> Also please make checkpatch.pl happy before resending, thanks. > --- > > > leds: pca955x: fix -Wvoid-pointer-to-enum-cast warning > --- > Note: I've opted to keep the initial `enum pca955x_type` cast and just > place the uintptr_t cast first to silence the warning. It seemed weird > to me to see the same variable being assigned to two different casted > values within just a few lines. > --- > drivers/leds/leds-pca955x.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/leds/leds-pca955x.c b/drivers/leds/leds-pca955x.c > index b10e1ef38db0..1d7fa0cd97bf 100644 > --- a/drivers/leds/leds-pca955x.c > +++ b/drivers/leds/leds-pca955x.c > @@ -484,7 +484,7 @@ static int pca955x_probe(struct i2c_client *client) > const void *md = device_get_match_data(&client->dev); > > if (md) { > - chip_type = (enum pca955x_type)md; > + chip_type = (enum pca955x_type)(uintptr_t)md; > } else { > const struct i2c_device_id *id = i2c_match_id(pca955x_id, > client); > > --- > base-commit: 2ccdd1b13c591d306f0401d98dedc4bdcd02b421 > change-id: 20230816-void-drivers-leds-leds-pca955x-7002cc67a291 > > Best regards, > -- > Justin Stitt <justinstitt@xxxxxxxxxx> > -- Lee Jones [李琼斯]