Hello Jiri,
+};
+
+static const char * const mode[] = {
This is not a wise name.
What do you suggest? For me, the 'mode' here was the most accurate.
It describes how the trigger should behave.
How about
* action
* switch
* tty_trigger
+ [TTY_LED_CNT] = "TD/RD", // Trasmit Data / Receive Data
+ [TTY_LED_CTS] = "CTS", // CTS Clear To Send
+ [TTY_LED_DSR] = "DSR", // DSR Data Set Ready
+ [TTY_LED_CAR] = "CAR", // CAR Data Carrier Detect (DCD)
+ [TTY_LED_RNG] = "RNG", // RNG Ring Indicator (RI)
};
static void ledtrig_tty_restart(struct ledtrig_tty_data
*trigger_data)
@@ -21,6 +38,74 @@ static void ledtrig_tty_restart(struct
ledtrig_tty_data *trigger_data)
schedule_delayed_work(&trigger_data->dwork, 0);
}
Best regards
-- Florian