On Wed, Aug 24, 2022 at 5:04 PM Henning Schild <henning.schild@xxxxxxxxxxx> wrote: > > Add GPIO support for Nuvoton NCT6116 chip. Nuvoton SuperIO chips are > very similar to the ones from Fintek. In other subsystems they also > share drivers and are called a family of drivers. > > For the GPIO subsystem the only difference is that the direction bit is > reversed and that there is only one data bit per pin. On the SuperIO > level the logical device is another one. > > On a chip level we do not have a manufacturer ID to check and also no > revision. ... > +#define gpio_dir_invert(type) ((type) == nct6116d) > +#define gpio_data_single(type) ((type) == nct6116d) What you are trying to do here is to put GPIO maintainers / heavy contributors on a minefield (basically moving your job to their shoulders). Please, provide a proper namespace and not gpio_ one. I'm talking in my "GPIO heavy contributor" hat on. With that fixed I can survive w/o pr_fmt() being in this patch. If you are going to address this, you may add my tag in a new version. -- With Best Regards, Andy Shevchenko