On 11/05/2022 08:45, Petr Mladek wrote: > [...] > DIE_OOPS and PANIC_NOTIFIER are from different enum. > It feels like comparing apples with oranges here. > > IMHO, the proper way to unify the two notifiers is > a check of the @self parameter. Something like: > > static int trace_die_panic_handler(struct notifier_block *self, > unsigned long ev, void *unused) > { > if (self == trace_die_notifier && val != DIE_OOPS) > goto out; > > ftrace_dump(ftrace_dump_on_oops); > out: > return NOTIFY_DONE; > } > > Best Regards, > Petr OK Petr, thanks - will implement your suggestion in V2 (CC Steven) Cheers!