This series aims to add a led-backlight driver, similar to pwm-backlight, but using a LED class device underneath. A few years ago (2015), Tomi Valkeinen posted a series implementing a backlight driver on top of a LED device: https://patchwork.kernel.org/patch/7293991/ https://patchwork.kernel.org/patch/7294001/ https://patchwork.kernel.org/patch/7293981/ The discussion stopped because Tomi lacked the time to work on it. changes in v10: - Provide a YAML schema instead of text file for the documentation of the LED backlight device-tree bindings. - Add a short description of how the LED properties should be named in the common LED binding documentation. (new patch) - rename property "default-brightness-level" as "default-brightness", following the majority here. changes in v9: - let to_of_node() check if the fwnode is actually a of_node - add some checks in of_led_get() - let dev_of_node() do the check about OF availabilty - refactor led_bl_probe() to register a cleanup function with devm_add_action_or_reset(). This simplifies the error handling (which was not 100% done in v7) and allows to get rid of led_bl_remove() changes in v8: - use class_find_device_by_of_node() instead of class_find_device() - renamed devm_led_get() as devm_of_led_get() changes in v7: - rebased on top of linux-leds/for-next - populate the of_node member of the LED device if fwnode is a of_node (this is a new patch and the first of the series). - devm_led_get() works only when the device tree is used. Add a few checks for that. changes in v6: - trim the list of included headers - remove useless definition of BKL_FULL_BRIGHTNESS changes in v5: - removed LED brightness scaling - disable sysfs the interface of the LEDs when used by the backlight device changes in v4: - fix dev_err() messages and commit logs following the advices of Pavel - cosmetic changes (indents, getting rid of "? 1 : 0" in led_match_led_node()) changes in v3: - dt binding: don't limit the brightness range to 0-255. Use the range of the underlying LEDs. as a side-effect, all LEDs must now have the same range - driver: Adapt to dt binding update. - driver: rework probe() for clarity and remove the remaining goto. changes in v2: - handle more than one LED. - don't make the backlight device a child of the LED controller. - make brightness-levels and default-brightness-level optional - removed the option to use a GPIO enable. - removed the option to use a regulator. It should be handled by the LED core - don't make any change to the LED core (not needed anymore) Jean-Jacques Hiblot (4): leds: populate the device's of_node leds: Add managed API to get a LED from a device driver dts-bindings: leds: Document the naming requirement for LED properties dt-bindings: backlight: Add led-backlight binding Tomi Valkeinen (2): leds: Add of_led_get() and led_put() backlight: add led-backlight driver .../leds/backlight/led-backlight.yaml | 55 ++++ .../devicetree/bindings/leds/common.txt | 20 +- drivers/leds/led-class.c | 103 ++++++- drivers/video/backlight/Kconfig | 7 + drivers/video/backlight/Makefile | 1 + drivers/video/backlight/led_bl.c | 258 ++++++++++++++++++ include/linux/leds.h | 6 + 7 files changed, 446 insertions(+), 4 deletions(-) create mode 100644 Documentation/devicetree/bindings/leds/backlight/led-backlight.yaml create mode 100644 drivers/video/backlight/led_bl.c -- 2.17.1