Bryan Wu <cooloney@xxxxxxxxx> writes: > On Mon, Dec 16, 2013 at 5:26 PM, Bryan Wu <cooloney@xxxxxxxxx> wrote: >> On Mon, Dec 16, 2013 at 4:08 PM, Ben Gamari <bgamari.foss@xxxxxxxxx> wrote: >>> This can be useful in debugging devicetrees. >>> >> >> OK, I will merge this. >> > > >> Thanks, >> -Bryan >> >>> Signed-off-by: Ben Gamari <bgamari.foss@xxxxxxxxx> >>> --- >>> drivers/leds/leds-pwm.c | 4 ++-- >>> 1 file changed, 2 insertions(+), 2 deletions(-) >>> >>> diff --git a/drivers/leds/leds-pwm.c b/drivers/leds/leds-pwm.c >>> index b31d8e9..707a82a 100644 >>> --- a/drivers/leds/leds-pwm.c >>> +++ b/drivers/leds/leds-pwm.c >>> @@ -165,8 +165,8 @@ static int led_pwm_probe(struct platform_device *pdev) >>> if (IS_ERR(led_dat->pwm)) { >>> ret = PTR_ERR(led_dat->pwm); >>> dev_err(&pdev->dev, >>> - "unable to request PWM for %s\n", >>> - cur_led->name); >>> + "unable to request PWM for %s: error=%d\n", > > Oh, hold on, this line has more than 80 characters. Please fix this > coding style error. > Would this not fall under the "unless" clause of the kernel style guidelines, Statements longer than 80 columns will be broken into sensible chunks, unless exceeding 80 columns significantly increases readability and does not hide information. The line is 82 characters long by my count and there is no reasonable way to break it. The only fix I can think of here is to introduce a local variable for the format string but in my opinion this is far less readable than what we currently have. Which would you prefer? Cheers, - Ben
Attachment:
pgpUu0vLg2Weh.pgp
Description: PGP signature