On Wed, Feb 19, 2025 at 05:31:40PM -0800, Nicolin Chen wrote: > A "fault_data" was added exclusively for the iommufd_fault_iopf_handler() > used by IOPF/PRI use cases, along with the attach_handle. Now, the iommufd > version of the sw_msi function will reuse the attach_handle and fault_data > for a non-fault case. > > Rename "fault_data" to "iommufd_hwpt" so as not to confine it to a "fault" > case. Move it into a union to be the iommufd private pointer. A following > patch will move the iova_cookie to the union for dma-iommu too after the > iommufd_sw_msi implementation is added. > > Since we have two unions now, add some simple comments for readability. > > Signed-off-by: Nicolin Chen <nicolinc@xxxxxxxxxx> > --- > include/linux/iommu.h | 6 ++++-- > drivers/iommu/iommufd/fault.c | 2 +- > drivers/iommu/iommufd/hw_pagetable.c | 2 +- > 3 files changed, 6 insertions(+), 4 deletions(-) Reviewed-by: Jason Gunthorpe <jgg@xxxxxxxxxx> Jason