Re: [PATCH 3/4] drivers: base: test: Drop "devm" from platform-device-test names

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi,

On Tue, Dec 10, 2024 at 11:13:32AM -0800, Brian Norris wrote:
> This is a reasonably-helpful base for generic platform_device tests, and
> I'd like to add more tests that aren't specifically about "devm"
> functions. Drop the devm namings for the suite, for clarity.
> 
> Signed-off-by: Brian Norris <briannorris@xxxxxxxxxxxx>
> ---
> 
>  drivers/base/test/platform-device-test.c | 14 +++++++-------
>  1 file changed, 7 insertions(+), 7 deletions(-)
> 
> diff --git a/drivers/base/test/platform-device-test.c b/drivers/base/test/platform-device-test.c
> index ea05b8785743..fd871bb9e143 100644
> --- a/drivers/base/test/platform-device-test.c
> +++ b/drivers/base/test/platform-device-test.c
> @@ -15,7 +15,7 @@ struct test_priv {
>  	struct device *dev;
>  };
>  
> -static int platform_device_devm_init(struct kunit *test)
> +static int platform_device_init(struct kunit *test)
>  {
>  	struct test_priv *priv;
>  
> @@ -203,7 +203,7 @@ static void probed_platform_device_devm_register_get_unregister_with_devm_test(s
>  	platform_driver_unregister(&fake_driver);
>  }
>  
> -static struct kunit_case platform_device_devm_tests[] = {
> +static struct kunit_case platform_device_tests[] = {
>  	KUNIT_CASE(platform_device_devm_register_unregister_test),
>  	KUNIT_CASE(platform_device_devm_register_get_unregister_with_devm_test),
>  	KUNIT_CASE(probed_platform_device_devm_register_unregister_test),
> @@ -211,13 +211,13 @@ static struct kunit_case platform_device_devm_tests[] = {
>  	{}
>  };
>  
> -static struct kunit_suite platform_device_devm_test_suite = {
> -	.name = "platform-device-devm",
> -	.init = platform_device_devm_init,
> -	.test_cases = platform_device_devm_tests,
> +static struct kunit_suite platform_device_test_suite = {
> +	.name = "platform-device",
> +	.init = platform_device_init,
> +	.test_cases = platform_device_tests,
>  };

The rest of the patches look ok to me, but it still seems like it tests
something different (ie, devm actions) so I don't see why we should
group them in the same test suite.

Maxime

Attachment: signature.asc
Description: PGP signature


[Index of Archives]     [Linux Wireless]     [Linux Kernel]     [ATH6KL]     [Linux Bluetooth]     [Linux Netdev]     [Kernel Newbies]     [Share Photos]     [IDE]     [Security]     [Git]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux ATA RAID]     [Samba]     [Device Mapper]

  Powered by Linux