On Mon, Aug 26 2024 at 12:45, Christophe Leroy wrote: > Le 26/08/2024 à 10:58, Jason A. Donenfeld a écrit : >> On Mon, Aug 26, 2024 at 10:37:49AM +0200, Christophe Leroy wrote: >>> >>> >>> Le 26/08/2024 à 10:07, Jason A. Donenfeld a écrit : >>>> On Thu, Aug 22, 2024 at 09:13:10AM +0200, Christophe Leroy wrote: >>>>> >>>>> +#define _PAGE_SIZE (1UL << CONFIG_PAGE_SHIFT) >>>>> +#define _PAGE_MASK (~(_PAGE_SIZE - 1)) >>>> >>>> If PAGE_SIZE isn't defined at this point, why not just call it PAGE_SIZE >>>> instead of _PAGE_SIZE? But if that's the case, why not put the vdso >>>> definition of PAGE_SIZE into some vdso header included by this file? >>> >>> It was working ok on powerpc but on x86 I got: >> >> Seems like there might be some more fiddling to do, then? Or did you >> conclude it's impossible? > > Maybe someone who knows x86 in details could helps but after a first > look I gave up because it looks very x86 specific, indeed that's > x86/asm/vdso/gettimeofday.h that pulls several x86/asm/ headers , and > the same type of issue might arise for any new architecture coming in. Of course :) > For me it looked cleaner to just do as commit cffaefd15a8f ("vdso: Use > CONFIG_PAGE_SHIFT in vdso/datapage.h") and not use PAGE_SIZE at all. But > I didn't want to directly use (1UL << CONFIG_PAGE_SHIFT) and (~(1UL << > (CONFIG_PAGE_SHIFT - 1))) in the code directly hence the new macros with > a leading underscore to avoid any conflict with existing macros. #ifndef PAGE_SIZE # define #endif Perhaps? Thanks, tglx