Re: [PATCH v4 05/10] platform: Add test managed platform_device/driver APIs

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Fri, 3 May 2024 at 09:04, Stephen Boyd <sboyd@xxxxxxxxxx> wrote:
>
> Quoting David Gow (2024-05-01 00:55:46)
> > On Tue, 23 Apr 2024 at 07:24, Stephen Boyd <sboyd@xxxxxxxxxx> wrote:
> > > diff --git a/Documentation/dev-tools/kunit/api/platformdevice.rst b/Documentation/dev-tools/kunit/api/platformdevice.rst
> > > new file mode 100644
> > > index 000000000000..b228fb6558c2
> > > --- /dev/null
> > > +++ b/Documentation/dev-tools/kunit/api/platformdevice.rst
> > > @@ -0,0 +1,10 @@
> > > +.. SPDX-License-Identifier: GPL-2.0
> > > +
> > > +===================
> > > +Platform Device API
> > > +===================
> > > +
> > > +The KUnit platform device API is used to test platform devices.
> > > +
> > > +.. kernel-doc:: drivers/base/test/platform_kunit.c
> > > +   :export:
> > > diff --git a/drivers/base/test/Makefile b/drivers/base/test/Makefile
> > > index e321dfc7e922..740aef267fbe 100644
> > > --- a/drivers/base/test/Makefile
> > > +++ b/drivers/base/test/Makefile
> > > @@ -1,8 +1,11 @@
> > >  # SPDX-License-Identifier: GPL-2.0
> > >  obj-$(CONFIG_TEST_ASYNC_DRIVER_PROBE)  += test_async_driver_probe.o
> > >
> > > +obj-$(CONFIG_KUNIT) += platform_kunit.o
> > > +
> >
> > Do we want this to be part of the kunit.ko module (and hence,
> > probably, under lib/kunit), or to keep this as a separate module.
> > I'm tempted, personally, to treat this as a part of KUnit, and have it
> > be part of the same module. There are a couple of reasons for this:
> > - It's nice to have CONFIG_KUNIT produce only one module. If we want
> > this to be separate, I'd be tempted to put it behind its own kconfig
> > entry.
> > - The name platform_kunit.ko suggests (to me, at least) that this is
> > the test for platform devices, not the implementation of the helper.
>
> I was following *_kunit as "helpers" and *_test as the test. Only
> loosely based on the documentation that mentions to use _test or _kunit
> for test files. Maybe it should have _kunit_helpers postfix?

Yeah, the style guide currently suggests that *_test is the default
for tests, but that _kunit may also be used for tests if _test is
already used for non-KUnit tests:
https://docs.kernel.org/dev-tools/kunit/style.html#test-file-and-module-names

DRM has drm_kunit_helpers, so _kunit_helpers seems like a good suffix
to settle on.

> Following the single module design should I merge the tests for this
> code into kunit-test.c? And do the same sort of thing for clk helpers?
> That sounds like it won't scale very well if everything is in one module.

I don't think it's as important that the tests live in the same
module. It's nice from an ergonomic point-of-view to only have to
modprobe the one thing, but we've already let that ship sail somewhat
with string-stream-test.

Either way, splitting up kunit-test.c is something we'll almost
certainly want to do at some point, and we can always put them into
the same module even if they're different source files if we have to.

>
> Shouldn't the wrapper code for subsystems live in those subsystems like
> drm_kunit_helpers.c does? Maybe the struct device kunit wrappers should
> be moved out to drivers/base/? lib/kunit can stay focused on providing
> pure kunit code then.

I tend to agree that wrapper code for subsystems should live in those
subsystems, especially if the subsystems are relatively self-contained
(i.e., the helpers are used to test that subsystem itself, rather than
exported for other parts of the kernel to use to test interactions
with said subsystem). For 'core' parts of the kernel, I think it makes
it easier to make these obviously part of KUnit (e.g. kunit_kzalloc()
is easier to have within KUnit, rather than as a part of the
allocators).

The struct device wrappers have the problem that they rely on the
kunit_bus being registered, which is currently done when the kunit
module is loaded. So it hooks more deeply into KUnit than is
comfortable to do from drivers/base. So we've treated it as a 'core'
part of the kernel.

Ultimately, it's a grey area, so I can live with this going either
way, depending on the actual helpers, so long as we don't end up with
lots of half-in/half-out helpers, which behave a bit like both. (For
example, at the moment, helpers which live outside lib/kunit are
documented and have headers in the respective subsystems'
directories.)

FWIW, my gut feeling for what's "most consistent" with what we've done
so far is:
1. platform_device helpers should live alongside the current managed
device stuff, which is currently in lib/kunit
2. clk helpers should probably live in clk
3. of/of_overlay sits a bit in the middle, but having thought more
about it, it'd probably lean towards having it be part of 'of', not
'kunit.

But all of this is, to some extent, just bikeshedding, so as long as
we pick somewhere to put them, and don't mix things up too much, I
don't think it matters exactly what side of this fuzzy line they end
up on.

> >
> > I probably can be persuaded otherwise if you've got a strong
> > preference for it to stay as-is, though.
> >
> > > diff --git a/drivers/base/test/platform_kunit.c b/drivers/base/test/platform_kunit.c
> > > new file mode 100644
> > > index 000000000000..54af6db2a6d8
> > > --- /dev/null
> > > +++ b/drivers/base/test/platform_kunit.c
> > > @@ -0,0 +1,174 @@
> > > +// SPDX-License-Identifier: GPL-2.0
> > > +/*
> > > + * Test managed platform driver
> > > + */
> > > +
> > > +#include <linux/device/driver.h>
> > > +#include <linux/platform_device.h>
> > > +
> > > +#include <kunit/platform_device.h>
> > > +#include <kunit/resource.h>
> > > +
> > > +/**
> > > + * platform_device_alloc_kunit() - Allocate a KUnit test managed platform device
> > > + * @test: test context
> > > + * @name: device name of platform device to alloc
> > > + * @id: identifier of platform device to alloc.
> > > + *
> > > + * Allocate a test managed platform device. The device is put when the test completes.
> > > + *
> > > + * Return: Allocated platform device on success, NULL on failure.
> > > + */
> > > +struct platform_device *
> > > +platform_device_alloc_kunit(struct kunit *test, const char *name, int id)
> >
> > I'd prefer, personally, this be named something like
> > kunit_platform_device_alloc(), to match the existing
> > kunit_device_register() functions.
> >
> >
> > > +{
> > > +       struct platform_device *pdev;
> > > +
> > > +       pdev = platform_device_alloc(name, id);
> > > +       if (!pdev)
> > > +               return NULL;
> > > +
> > > +       if (kunit_add_action_or_reset(test, (kunit_action_t *)&platform_device_put, pdev))
> >
> > Alas, casting function pointers to kunit_action_t* breaks CFI. It's
> > worth using a wrapper, which can be created with the
> > KUNIT_DEFINE_ACTION_WRAPPER() macro, e.g.
> >
> > KUNIT_DEFINE_ACTION_WRAPPER(platform_device_put_wrapper,
> > platform_device_put, struct platform_device *);
>
> Thanks. I missed that.
>
> >
> > > +               return NULL;
> > > +
> > > +       return pdev;
> > > +}
> > > +EXPORT_SYMBOL_GPL(platform_device_alloc_kunit);
> > > +
> > > +static void platform_device_add_kunit_exit(struct kunit_resource *res)
> > > +{
> > > +       struct platform_device *pdev = res->data;
> > > +
> > > +       platform_device_unregister(pdev);
> > > +}
> > > +
> > > +static bool
> > > +platform_device_alloc_kunit_match(struct kunit *test,
> > > +                                 struct kunit_resource *res, void *match_data)
> > > +{
> > > +       struct platform_device *pdev = match_data;
> > > +
> > > +       return res->data == pdev;
> > > +}
> > > +
> > > +/**
> > > + * platform_device_add_kunit() - Register a KUnit test managed platform device
> > > + * @test: test context
> > > + * @pdev: platform device to add
> > > + *
> > > + * Register a test managed platform device. The device is unregistered when the
> > > + * test completes.
> > > + *
> > > + * Return: 0 on success, negative errno on failure.
> > > + */
> > > +int platform_device_add_kunit(struct kunit *test, struct platform_device *pdev)
> >
> > As above, I'd lean towards naming this kunit_platform_device_add() for
> > consistency with the other KUnit device helpers.
> >
> > > +{
> > > +       struct kunit_resource *res;
> > > +       int ret;
> > > +
> > > +       ret = platform_device_add(pdev);
> > > +       if (ret)
> > > +               return ret;
> > > +
> > > +       res = kunit_find_resource(test, platform_device_alloc_kunit_match, pdev);
> > > +       if (res) {
> > > +               /*
> > > +                * Transfer the reference count of the platform device if it was
> > > +                * allocated with platform_device_alloc_kunit(). In that case,
> > > +                * calling platform_device_put() leads to reference count
> > > +                * underflow because platform_device_unregister() does it for
> > > +                * us and we call platform_device_unregister() from
> > > +                * platform_device_add_kunit_exit().
> > > +                *
> > > +                * Usually callers transfer the refcount from
> > > +                * platform_device_alloc() to platform_device_add() and simply
> > > +                * call platform_device_unregister() when done, but with kunit
> > > +                * we have to keep this straight by redirecting the free
> > > +                * routine for the resource.
> > > +                */
> > > +               res->free = platform_device_add_kunit_exit;
> > > +               kunit_put_resource(res);
> > > +       } else if (kunit_add_action_or_reset(test,
> > > +                                            (kunit_action_t *)&platform_device_unregister,
> > > +                                            pdev)) {
> >
> > Nit: We don't want to cast directly to kunit_action_t *, as that
> > breaks CFI. Can we use KUNIT_DEFINE_ACTION_WRAPPER()?
> >
> > > +               return -ENOMEM;
> >
> > Nit: This is fine, as kunit_add_action_or_reset() only returns 0 or
> > -ENOMEM at the moment, but it could cause problems down the line if we
> > ever want to return a different error. I don't think that's
> > particularly likely, but it might be nicer to properly propagate the
> > error.
>
> I will propagate the return value.
>
> >
> > > +       }
> > > +
> > > +       return 0;
> > > +}
> > > +EXPORT_SYMBOL_GPL(platform_device_add_kunit);
> > > +
> > > +/**
> > > + * platform_driver_register_kunit() - Register a KUnit test managed platform driver
> > > + * @test: test context
> > > + * @drv: platform driver to register
> > > + *
> > > + * Register a test managed platform driver. This allows callers to embed the
> > > + * @drv in a container structure and use container_of() in the probe function
> > > + * to pass information to KUnit tests. It can be assumed that the driver has
> > > + * probed when this function returns.
> > > + *
> > > + * Example
> > > + *
> > > + * .. code-block:: c
> > > + *
> > > + *     struct kunit_test_context {
> > > + *             struct platform_driver pdrv;
> > > + *             const char *data;
> > > + *     };
> > > + *
> > > + *     static inline struct kunit_test_context *
> > > + *     to_test_context(struct platform_device *pdev)
> > > + *     {
> > > + *             return container_of(to_platform_driver(pdev->dev.driver),
> > > + *                                 struct kunit_test_context,
> > > + *                                 pdrv);
> > > + *     }
> > > + *
> > > + *     static int kunit_platform_driver_probe(struct platform_device *pdev)
> > > + *     {
> > > + *             struct kunit_test_context *ctx;
> > > + *
> > > + *             ctx = to_test_context(pdev);
> > > + *             ctx->data = "test data";
> > > + *
> > > + *             return 0;
> > > + *     }
> > > + *
> > > + *     static void kunit_platform_driver_test(struct kunit *test)
> > > + *     {
> > > + *             struct kunit_test_context *ctx;
> > > + *
> > > + *             ctx = kunit_kzalloc(test, sizeof(*ctx), GFP_KERNEL);
> > > + *             KUNIT_ASSERT_NOT_ERR_OR_NULL(test, ctx);
> > > + *
> > > + *             ctx->pdrv.probe = kunit_platform_driver_probe;
> > > + *             ctx->pdrv.driver.name = "kunit-platform";
> > > + *             ctx->pdrv.driver.owner = THIS_MODULE;
> > > + *
> > > + *             KUNIT_EXPECT_EQ(test, 0, platform_driver_register_kunit(test, &ctx->pdrv));
> > > + *             KUNIT_EXPECT_STREQ(test, ctx->data, "test data");
> > > + *     }
> > > + *
> > > + * Return: 0 on success, negative errno on failure.
> > > + */
> > > +int platform_driver_register_kunit(struct kunit *test,
> > > +                                  struct platform_driver *drv)
> >
> > As above, I'd prefer kunit_platform_driver_register()
> >
> > > +{
> > > +       int ret;
> > > +
> > > +       ret = platform_driver_register(drv);
> > > +       if (ret)
> > > +               return ret;
> > > +
> > > +       /*
> > > +        * Wait for the driver to probe (or at least flush out of the deferred
> > > +        * workqueue)
> > > +        */
> > > +       wait_for_device_probe();
> >
> > Personally, I don't mind if this wrapper waits here (even if it makes
> > it less of a 'pure' wrapper), so long as we document it. Can you think
> > of any cases where we explicitly want _not_ to wait in a test?
> >
>
> I don't like it because it's not deterministic. The function doesn't
> take any struct device to wait for. I've already written the code to use
> a completion, and it works well enough so I'll just do that. Then we
> don't have to worry if this API goes away, or that it doesn't actually
> determine if the driver has probed the device.

Sounds good!

Cheers,
-- David

Attachment: smime.p7s
Description: S/MIME Cryptographic Signature


[Index of Archives]     [Linux Wireless]     [Linux Kernel]     [ATH6KL]     [Linux Bluetooth]     [Linux Netdev]     [Kernel Newbies]     [Share Photos]     [IDE]     [Security]     [Git]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux ATA RAID]     [Samba]     [Device Mapper]

  Powered by Linux