在 2023/8/3 19:36, Mark Brown 写道:
On Thu, Aug 03, 2023 at 03:02:31PM +0800, Zeng Heng wrote:
@@ -364,6 +376,20 @@ static const struct hwcap_data {
.hwcap_bit = HWCAP2_SVE_EBF16,
.cpuinfo = "sveebf16",
},
+ {
+ .name = "RCpc load-acquire",
+ .at_hwcap = AT_HWCAP,
+ .hwcap_bit = HWCAP_LRCPC,
+ .cpuinfo = "lrcpc",
+ .sigill_fn = lrcpc_sigill,
+ },
The table is roughly ordered by feature name, it'd be good to keep it
that way (apart from anything else it minimises merge conflicts). It'd
also be good to follow the existing style and use the FEAT_ name for the
feature as the display name, if there isn't one then at least something
similarly all caps like the name of the ID register field?
Thanks for review, and v2 would be sent later.
Zeng Heng