On Thu, Apr 20, 2023 at 08:03:54PM +0300, Vladimir Oltean wrote: > On Thu, Apr 20, 2023 at 04:22:04PM +0200, Simon Horman wrote: > > > - /* If link is up, enable MAC Merge right away */ > > > - if (!!(priv->active_offloads & ENETC_F_QBU) && > > > - !(val & ENETC_MMCSR_LINK_FAIL)) > > > - val |= ENETC_MMCSR_ME; > > > + /* If link is up, enable/disable MAC Merge right away */ > > > + if (!(val & ENETC_MMCSR_LINK_FAIL)) { > > > + if (!!(priv->active_offloads & ENETC_F_QBU)) > > > > nit: The !!() seems unnecessary, > > I wonder if it can be written in a simpler way as: > > > > if (priv->active_offloads & ENETC_F_QBU) > > I agree. Normally I omit the double negation in simple statements like this. > Here I didn't, because the expression was split into 2 "if" conditions, > and I kept the individual terms as-is for some reason. > > Since the generated object code is absolutely the same either way, I would not > resend just for minor style comments such as this one, if you don't mind. > However, I do appreciate the review and I'll pay more attention to this > detail in the future. Thanks. I agree the result should be same. No need to resend because of this.