On Thu, Sep 08, 2022 at 03:44:29PM -0700, Reinette Chatre wrote: > Hi Jarkko and Vijay, > > On 9/4/2022 7:04 PM, Jarkko Sakkinen wrote: > > From: Vijay Dhanraj <vijay.dhanraj@xxxxxxxxx> > > > > Add a new test case which is same as augment_via_eaccept but adds a > > larger number of EPC pages to stress test EAUG via EACCEPT. > > > > Signed-off-by: Vijay Dhanraj <vijay.dhanraj@xxxxxxxxx> > > Signed-off-by: Jarkko Sakkinen <jarkko@xxxxxxxxxx> > > --- > > ... > > > diff --git a/tools/testing/selftests/sgx/main.c b/tools/testing/selftests/sgx/main.c > > index 78c3b913ce10..e596b45bc5f8 100644 > > --- a/tools/testing/selftests/sgx/main.c > > +++ b/tools/testing/selftests/sgx/main.c > > @@ -22,8 +22,10 @@ > > #include "main.h" > > > > static const size_t ENCL_HEAP_SIZE_DEFAULT = PAGE_SIZE; > > +static const unsigned long TIMEOUT_DEFAULT = 900; > > I am not sure about the naming here ... it is _very_ close to > (and thus appears to be in the same namespace as) > TEST_TIMEOUT_DEFAULT from the included kselftest_harness.h. > > This is surely a nitpick but how about SGX_TEST_TIMEOUT_DEFAULT? Agreed, I would use ENCL_TEST_TIMEOUT_DEFAULT (better match with existing names). > > > static const uint64_t MAGIC = 0x1122334455667788ULL; > > static const uint64_t MAGIC2 = 0x8877665544332211ULL; > > + > > There is an extra empty line here ... but it looks like intended code > organization? Yeah, I think it'd make sense to have it there and would not be productive to make it a separate patch. > > > vdso_sgx_enter_enclave_t vdso_sgx_enter_enclave; > > > > /* > > > Apart from the naming comment this addition looks good. > > This is a valuable addition to the SGX tests. > > Reinette Thank you. BR, Jarkko