On 4/19/22 19:40, Thomas Huth wrote: > On 14/04/2022 14.48, Janis Schoetterl-Glausch wrote: >> On 4/14/22 12:53, Thomas Huth wrote: >>> The memop test currently does not have any output (unless one of the >>> TEST_ASSERT statement fails), so it's hard to say for a user whether >>> a certain new sub-test has been included in the binary or not. Let's >>> make this a little bit more user-friendly and include some TAP output >>> via the kselftests.h interface. >>> >>> Signed-off-by: Thomas Huth <thuth@xxxxxxxxxx> >>> --- >>> tools/testing/selftests/kvm/s390x/memop.c | 90 ++++++++++++++++++----- >>> 1 file changed, 73 insertions(+), 17 deletions(-) >>> >>> diff --git a/tools/testing/selftests/kvm/s390x/memop.c b/tools/testing/selftests/kvm/s390x/memop.c >>> index b04c2c1b3c30..a2783d9afcac 100644 >>> --- a/tools/testing/selftests/kvm/s390x/memop.c >>> +++ b/tools/testing/selftests/kvm/s390x/memop.c >>> @@ -12,6 +12,7 @@ >>> #include "test_util.h" >>> #include "kvm_util.h" >>> +#include "kselftest.h" >>> enum mop_target { >>> LOGICAL, >>> @@ -648,33 +649,88 @@ static void test_errors(void) >>> kvm_vm_free(t.kvm_vm); >>> } >>> +struct testdef { >>> + const char *name; >>> + void (*test)(void); >>> + bool needs_extension; >> >> Please make this numeric. You could also rename it to required_extension or similar. > [...] >>> + >>> + for (idx = 0; idx < ARRAY_SIZE(testlist); idx++) { >>> + if (!testlist[idx].needs_extension || extension_cap) { >> >> Then check here that extension_cap >= the required extension. >> This way the test can easily be adapted in case of future extensions. > > Not sure whether a ">=" will really be safe, since a future extension does not necessarily assert that previous extensions are available at the same time. Hmm, I intend for that to hold. In any case, for the existing extension we have committed to it, e.g. the documentation says: Absolute accesses are permitted for the VM ioctl if KVM_CAP_S390_MEM_OP_EXTENSION is > 0. So, if we introduce an extension and allow for it to be removed with a higher extension number, when we add testing support for that extension we'd have to change the capability check, but the existing test case would not break. I guess the most flexible way would be to initialize the array in the middle of main, then you could do .skip = !extension_cap and in the future whatever expression makes sense, but it's kinda ugly and should not be necessary anyway. > > But I can still turn the bool into a numeric to make it a little bit more flexible for future use. > > Thomas >