On Thu, Apr 7, 2022 at 10:48 PM 'David Gow' via KUnit Development <kunit-dev@xxxxxxxxxxxxxxxx> wrote: > > Add a count of the total number of tests run (including skipped tests, > which do run a little bit until they decide to skip themselves) to the > summary line. > > Signed-off-by: David Gow <davidgow@xxxxxxxxxx> > --- > > This patch depends on: > https://lore.kernel.org/linux-kselftest/20220407223019.2066361-1-dlatypov@xxxxxxxxxx/ > > tools/testing/kunit/kunit_parser.py | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/tools/testing/kunit/kunit_parser.py b/tools/testing/kunit/kunit_parser.py > index 957907105429..da01998d29b1 100644 > --- a/tools/testing/kunit/kunit_parser.py > +++ b/tools/testing/kunit/kunit_parser.py > @@ -96,7 +96,7 @@ class TestCounts: > """ > statuses = [('Passed', self.passed), ('Failed', self.failed), > ('Crashed', self.crashed), ('Skipped', self.skipped), > - ('Errors', self.errors)] > + ('Errors', self.errors), ('Total', self.total())] Hmm, I've never really felt the need for a total to be printed out. We've had few enough tests and different statuses that the mental addition is easy enough. Bikeshedding: This current output of Passed: 40, Skipped: 2, Total: 42 feels a bit awkward to me. If we did print one out, I think it should probably go first, e.g. Ran 42 tests: 40 passed, 2 skipped. Wdyt? > return ', '.join('{}: {}'.format(s, n) for s, n in statuses if n > 0)