On Mon, Jul 26, 2021, David Matlack wrote: > On Mon, Jul 26, 2021 at 11:37:54AM -0700, Erdem Aktas wrote: > > Currently vm_create function only creates KVM_X86_LEGACY_VM type VMs. > > Changing the vm_create function to accept type parameter to create > > new VM types. > > > > Signed-off-by: Erdem Aktas <erdemaktas@xxxxxxxxxx> > > Reviewed-by: Sean Christopherson <seanjc@xxxxxxxxxx> *-by tags should not be added unless explicitly provided. IIRC, our internal gerrit will convert +1 to Reviewed-by, but I don't think that's the case here. This applies to all patches in this series. See "Using Reported-by:, Tested-by:, Reviewed-by:, Suggested-by: and Fixes:" in Documentation/process/submitting-patches.rst for more info. > > Reviewed-by: Peter Gonda <pgonda@xxxxxxxxxx> > > Reviewed-by: Marc Orr <marcorr@xxxxxxxxxx> > > Reviewed-by: Sagi Shahar <sagis@xxxxxxxxxx> > > Reviewed-by: David Matlack <dmatlack@xxxxxxxxxx> > > (aside from the nit below) > > > --- > > .../testing/selftests/kvm/include/kvm_util.h | 1 + > > tools/testing/selftests/kvm/lib/kvm_util.c | 29 +++++++++++++++++-- > > 2 files changed, 27 insertions(+), 3 deletions(-) > > > > diff --git a/tools/testing/selftests/kvm/include/kvm_util.h b/tools/testing/selftests/kvm/include/kvm_util.h > > index d53bfadd2..c63df42d6 100644 > > --- a/tools/testing/selftests/kvm/include/kvm_util.h > > +++ b/tools/testing/selftests/kvm/include/kvm_util.h > > @@ -88,6 +88,7 @@ int vcpu_enable_cap(struct kvm_vm *vm, uint32_t vcpu_id, > > void vm_enable_dirty_ring(struct kvm_vm *vm, uint32_t ring_size); > > > > struct kvm_vm *vm_create(enum vm_guest_mode mode, uint64_t phy_pages, int perm); > > +struct kvm_vm *__vm_create(enum vm_guest_mode mode, uint64_t phy_pages, int perm, int type); > > nit: Consider using a more readable function name such as > vm_create_with_type(). Ha! This is why I don't like doing internal reviews :-D Erdem originally had vm_create_type(), I suggested __vm_create() as the double underscore scheme is more common in the kernel for cases where there's a default wrapper and an inner helper that implements the full API. Convention aside, the argument againsts ...with_type() are that it doesn't scale, e.g. if someone adds another parameter parameter for which vm_create() provides a default, and it doesn't self-document the relationship between vm_create() and the inner helper, e.g. by convention, based on names alone I know that vm_create() likely is a wrapper around __vm_create(). Compare that with the existing vm_create_default_with_vcpus() vm_create_default() vm_create_with_vcpus() vm_create() where the relationship between all the helpers is not immediately clear, and vm_create_with_vcpus() is a misnomer because it does much more than call vm_create() and instantiate vCPUs, e.g. it also instantiates the IRQ chip and loads the test into guest memory.