On Wed, Dec 9, 2020 at 7:21 AM Daniel Latypov <dlatypov@xxxxxxxxxx> wrote: > > Don't use an O(nm) algorithm* and make it more readable by using a dict. > > *Most obviously, it does a nested for-loop over the entire other config. > A bit more subtle, it calls .entries(), which constructs a set from the > list for _every_ outer iteration. > > Signed-off-by: Daniel Latypov <dlatypov@xxxxxxxxxx> > --- Thanks! This works great here: I didn't time it to see how much faster it is, but it's clearly an improvement. Reviewed-by: David Gow <davidgow@xxxxxxxxxx> Cheers, -- David