On Thu, Jul 02, 2020 at 12:14AM -0700, David Gow wrote: > As discussed in [1], KUnit tests have hitherto not had a particularly > consistent naming scheme. This adds documentation outlining how tests > and test suites should be named, including how those names should be > used in Kconfig entries and filenames. > > [1]: > https://lore.kernel.org/linux-kselftest/202006141005.BA19A9D3@keescook/t/#u > > Signed-off-by: David Gow <davidgow@xxxxxxxxxx> > Reviewed-by: Kees Cook <keescook@xxxxxxxxxxxx> > --- ... > +An example Kconfig entry: > + > +.. code-block:: none > + > + config FOO_KUNIT_TEST > + tristate "KUnit test for foo" if !KUNIT_ALL_TESTS > + depends on KUNIT > + default KUNIT_ALL_TESTS > + help > + This builds unit tests for foo. > + > + For more information on KUnit and unit tests in general, please refer > + to the KUnit documentation in Documentation/dev-tools/kunit > + > + If unsure, say N > + > + > +Test Filenames > +============== > + > +Where possible, test suites should be placed in a separate source file in the > +same directory as the code being tested. > + > +This file should be named ``<suite>_kunit.c``. It may make sense to strip > +excessive namespacing from the source filename (e.g., ``firmware_kunit.c`` instead of > +``<drivername>_firmware.c``), but please ensure the module name does contain the > +full suite name. First of all, thanks for the talk yesterday! I only looked at this because somebody pasted the LKML link. :-) The example about excessive namespacing seems confusing. Was it supposed to be [...] firmware_kunit.c`` instead of ``<drivername>_firmware_kunit.c [...] ? While I guess this ship has sailed, and *_kunit.c is the naming convention now, I hope this is still just a recommendation and names of the form *-test.c are not banned! $> git grep 'KUNIT.*-test.o' drivers/base/power/Makefile:obj-$(CONFIG_PM_QOS_KUNIT_TEST) += qos-test.o drivers/base/test/Makefile:obj-$(CONFIG_KUNIT_DRIVER_PE_TEST) += property-entry-test.o fs/ext4/Makefile:obj-$(CONFIG_EXT4_KUNIT_TESTS) += ext4-inode-test.o kernel/Makefile:obj-$(CONFIG_SYSCTL_KUNIT_TEST) += sysctl-test.o lib/Makefile:obj-$(CONFIG_LIST_KUNIT_TEST) += list-test.o lib/kunit/Makefile:obj-$(CONFIG_KUNIT_TEST) += kunit-test.o lib/kunit/Makefile:obj-$(CONFIG_KUNIT_TEST) += string-stream-test.o lib/kunit/Makefile:obj-$(CONFIG_KUNIT_EXAMPLE_TEST) += kunit-example-test.o $> git grep 'KUNIT.*_kunit.o' # Returns nothing Just an idea: Maybe the names are also an opportunity to distinguish real _unit_ style tests and then the rarer integration-style tests. I personally prefer using the more generic *-test.c, at least for the integration-style tests I've been working on (KUnit is still incredibly valuable for integration-style tests, because otherwise I'd have to roll my own poor-man's version of KUnit, so thank you!). Using *_kunit.c for such tests is unintuitive, because the word "unit" hints at "unit tests" -- and having descriptive (and not misleading) filenames is still important. So I hope you won't mind if *-test.c are still used where appropriate. Thanks, -- Marco