On Mon, Jun 10, 2019 at 12:07:45PM +0100, Vincenzo Frascino wrote: > On 10/06/2019 11:31, Huw Davies wrote: > > On Mon, Jun 10, 2019 at 11:17:48AM +0100, Vincenzo Frascino wrote: > >> On 10/06/2019 10:27, Huw Davies wrote: > >>> On Thu, May 30, 2019 at 03:15:13PM +0100, Vincenzo Frascino wrote: > >>>> --- /dev/null > >>>> +++ b/include/vdso/datapage.h > >>>> @@ -0,0 +1,91 @@ > >>>> +/* SPDX-License-Identifier: GPL-2.0 */ > >>>> +#ifndef __VDSO_DATAPAGE_H > >>>> +#define __VDSO_DATAPAGE_H > >>>> + > >>>> +#ifdef __KERNEL__ > >>>> + > >>>> +#ifndef __ASSEMBLY__ > >>>> + > >>>> +#include <linux/bits.h> > >>>> +#include <linux/time.h> > >>>> +#include <linux/types.h> > >>>> + > >>>> +#define VDSO_BASES (CLOCK_TAI + 1) > >>>> +#define VDSO_HRES (BIT(CLOCK_REALTIME) | \ > >>>> + BIT(CLOCK_MONOTONIC) | \ > >>>> + BIT(CLOCK_BOOTTIME) | \ > >>>> + BIT(CLOCK_TAI)) > >>>> +#define VDSO_COARSE (BIT(CLOCK_REALTIME_COARSE) | \ > >>>> + BIT(CLOCK_MONOTONIC_COARSE)) > >>>> +#define VDSO_RAW (BIT(CLOCK_MONOTONIC_RAW)) > >>>> + > >>>> +#define CS_HRES_COARSE 0 > >>>> +#define CS_RAW 1 > >>> > >>> CS_HRES_COARSE seems like a confusing name choice to me. What you > >>> really mean is not RAW. > >>> > >>> How about CS_ADJ to indicate that its updated by adjtime? > >>> CS_XTIME might be another option. > >>> > >> > >> I divided the timers in 3 sets (HRES, COARSE, RAW), CS_HRES_COARSE refers to the > >> first two and CS_RAW to the third. I will ad a comment to explain the logic in > >> the next iteration. > > > > I'm thinking ahead about a possible CLOCK_MONOTONIC_RAW_COARSE (which > > would be useful at least for Wine). In that case you'd have four clock > > types non-raw and raw, each with either hres or coarse. > > > > Thanks for this, I was not aware of CLOCK_MONOTONIC_RAW_COARSE. > I tried to find, though, some details, but I could not find any. Could you > please provide some reference? It doesn't exist yet ;-) However it doesn't seem crazy that such a clock should exist. I was really using it to illustrate that raw / non-raw is orthogonal to hres / coarse. That being said, this really doesn't matter that much. Huw.