First of all, the change is wrong. We can't dereference "prop" after calling of_node_put(). You have to be a bit extra careful reviewing Markus's patches because a lot of the rest of us have blocked these messages so you're on your own in that way. On Wed, Oct 02, 2024 at 10:43:46PM +0200, Christophe Leroy wrote: > > > Le 02/10/2024 à 22:02, Markus Elfring a écrit : > > From: Markus Elfring <elfring@xxxxxxxxxxxxxxxxxxxxx> > > Date: Wed, 2 Oct 2024 21:50:27 +0200 > > > > An of_node_put(bk_node) call was immediately used after a pointer check > > for an of_get_property() call in this function implementation. > > Thus call such a function only once instead directly before the check. > > It seems pointless to perform a put immediately after a get. Shouldn't > of_find_property() be used instead ? And then of_property_read_string() > would probably be better. > > Maybe you can even use of_property_match_string(). The of_get_property() function doesn't do a get as in get/put, it just finds the property and returns it. It doesn't bump the reference count. It's a confusing name in that way. The The of_node_put() pairs with of_find_node_by_name(). regards, dan carpenter