nfc_llc_register() calls pass a string literal as the 'name' parameter. So kstrdup_const() can be used instead of kfree() to avoid a memory allocation in such cases. v2: Add a new helper function, nfc_llc_del_engine(), to reduce code duplication. This is needed to address Jakub Kicinski's comment about nfc_llc_exit() that was not updated in v1. v1: https://lore.kernel.org/all/6d2b8c390907dcac2e4dc6e71f1b2db2ef8abef1.1705744530.git.christophe.jaillet@xxxxxxxxxx/ Christophe JAILLET (2): nfc: hci: Introduce nfc_llc_del_engine() to reduce code duplication nfc: hci: Save a few bytes of memory when registering a 'nfc_llc' engine net/nfc/hci/llc.c | 20 +++++++++++--------- 1 file changed, 11 insertions(+), 9 deletions(-) -- 2.43.0