>> Add a jump target so that a bit of exception handling can be better reused >> in this function implementation. … >> +++ b/drivers/net/ethernet/broadcom/asp2/bcmasp.c >> @@ -1304,9 +1304,8 @@ static int bcmasp_probe(struct platform_device *pdev) >> intf = bcmasp_interface_create(priv, intf_node, i); >> if (!intf) { >> dev_err(dev, "Cannot create eth interface %d\n", i); >> - bcmasp_remove_intfs(priv); >> of_node_put(intf_node); >> - goto of_put_exit; >> + goto remove_intfs; >> } >> list_add_tail(&intf->list, &priv->intfs); >> i++; >> @@ -1331,6 +1330,7 @@ static int bcmasp_probe(struct platform_device *pdev) >> netdev_err(intf->ndev, >> "failed to register net_device: %d\n", ret); >> priv->destroy_wol(priv); >> +remove_intfs: >> bcmasp_remove_intfs(priv); >> goto of_put_exit; >> } >> -- >> 2.42.1 >> > nak. Doesn't save any lines of code. Would you get into the mood to take also another look at consequences for executable code? > Doesn't make things clearer or easier to follow. Maybe. > This doesn't seem like an improvement to me. Can this software implementation benefit from one function call less? Regards, Markus