On Sat, Oct 14, 2023 at 08:34:52AM +0200, Christophe JAILLET wrote: > Use struct_size() instead of hand writing it. > This is less verbose and more robust. > > Signed-off-by: Christophe JAILLET <christophe.jaillet@xxxxxxxxxx> > --- > v2: No change > > v1: https://lore.kernel.org/all/8be59c9e06fca8eff2f264abb4c2f74db0b19a9e.1696156198.git.christophe.jaillet@xxxxxxxxxx/ > > > This is IMHO more readable, even if not perfect. > > However (untested): > + new = kzalloc(size_add(struct_size(new, masks, size), > size_mul(sizeof(u64), size)), GFP_KERNEL); > looks completely unreadable to me. Thanks, this looks correct (and more readable) to me. Reviewed-by: Simon Horman <horms@xxxxxxxxxx>