On Tue, Jun 01, 2021 at 04:37:57PM +0300, Dan Carpenter wrote: > On Tue, Jun 01, 2021 at 09:00:33AM -0400, Nigel Christian wrote: > > In the case MICROREAD_CB_TYPE_READER_ALL clang reports a dead > > code warning. The error code is being directly passed to > > async_cb(). Fix this by passing the err variable, which is also > > done in another path. > > > > Addresses-Coverity: ("Unused value") > > Signed-off-by: Nigel Christian <nigel.l.christian@xxxxxxxxx> > > --- > > drivers/nfc/microread/microread.c | 2 +- > > 1 file changed, 1 insertion(+), 1 deletion(-) > > > > diff --git a/drivers/nfc/microread/microread.c b/drivers/nfc/microread/microread.c > > index 8d3988457c58..130b0f554016 100644 > > --- a/drivers/nfc/microread/microread.c > > +++ b/drivers/nfc/microread/microread.c > > @@ -367,7 +367,7 @@ static void microread_im_transceive_cb(void *context, struct sk_buff *skb, > > err = -EPROTO; > > kfree_skb(skb); > > info->async_cb(info->async_cb_context, NULL, > > - -EPROTO); > > + err); > > It would be better to just delete the "err = -EPROTO;" assignment. > > Literals are more readable. Avoid pointless indirection. Yeah, my bad. v2 sent! Thanks Dan! > > regards, > dan carpenter > >