On Fri, 2020-05-08 at 23:53 +0100, Colin King wrote: > From: Colin Ian King <colin.king@xxxxxxxxxxxxx> > > Currently the value for 'off' is computed using a multiplication and > a couple of statements later off is being incremented by len and > this value is never read. Clean up the code by removing the > multiplication and just increment off by len on each iteration. Also > use len instead of TG3_OCIR_LEN. I think this is a lot harder to read. > diff --git a/drivers/net/ethernet/broadcom/tg3.c b/drivers/net/ethernet/broadcom/tg3.c [] > @@ -10798,16 +10798,14 @@ static int tg3_init_hw(struct tg3 *tp, bool reset_phy) > static void tg3_sd_scan_scratchpad(struct tg3 *tp, struct tg3_ocir *ocir) > { > int i; > + u32 off, len = TG3_OCIR_LEN; > > - for (i = 0; i < TG3_SD_NUM_RECS; i++, ocir++) { > - u32 off = i * TG3_OCIR_LEN, len = TG3_OCIR_LEN; > - > + for (i = 0, off = 0; i < TG3_SD_NUM_RECS; i++, ocir++, off += len) { > tg3_ape_scratchpad_read(tp, (u32 *) ocir, off, len); > - off += len; > > if (ocir->signature != TG3_OCIR_SIG_MAGIC || > !(ocir->version_flags & TG3_OCIR_FLAG_ACTIVE)) > - memset(ocir, 0, TG3_OCIR_LEN); > + memset(ocir, 0, len); > } > } My preference would be for { int i; u32 off = 0; for (i = 0; i < TG3_SD_NUM_RECS; i++) { tg3_ape_scratchpad_read(tp, (u32 *)ocir, off, TC3_OCIR_LEN); if (ocir->signature != TG3_OCIR_SIG_MAGIC || !(ocir->version_flags & TG3_OCIR_FLAG_ACTIVE)) memset(ocir, 0, TG3_OCIR_LEN); off += TG3_OCIR_LEN; ocir++; }