On Fri, 21 Jun 2019, Markus Elfring wrote: > > I think that something like > > > > if (IS_ERR(e)) > > { > > <+... > > *dev_err(...) > > ...+> > > } > > > > would be more appropriate. Whether there is a return or not doesn't > > really matter. > > Do you find the following SmPL change specification useful and acceptable? > > > @deletion depends on patch@ > expression e; > @@ > e = devm_ioremap_resource(...); > if (IS_ERR(e)) > ( > -{ > - dev_err(...); > return (...); I still don't see the point of specifying return. Why not just S, where S is a statement metavariable? julia > -} > |{ I realize that you confuse conciseness with readability, but it would really look better to have the | on a line by itself. julia > <+... > - dev_err(...); > ...+> > } > ) > > > Would this approach need a version check for the Coccinelle software? Why would that be necessary?