Hi, On 29/03/2019 03:41, YueHaibing wrote: > Use PTR_ERR_OR_ZERO rather than if(IS_ERR(...)) + PTR_ERR > > Signed-off-by: YueHaibing <yuehaibing@xxxxxxxxxx> > --- > drivers/gpu/drm/omapdrm/dss/hdmi4_core.c | 5 +---- > 1 file changed, 1 insertion(+), 4 deletions(-) > > diff --git a/drivers/gpu/drm/omapdrm/dss/hdmi4_core.c b/drivers/gpu/drm/omapdrm/dss/hdmi4_core.c > index e384b95ad857..8287ade5ece0 100644 > --- a/drivers/gpu/drm/omapdrm/dss/hdmi4_core.c > +++ b/drivers/gpu/drm/omapdrm/dss/hdmi4_core.c > @@ -934,8 +934,5 @@ int hdmi4_core_init(struct platform_device *pdev, struct hdmi_core_data *core) > > res = platform_get_resource_byname(pdev, IORESOURCE_MEM, "core"); > core->base = devm_ioremap_resource(&pdev->dev, res); > - if (IS_ERR(core->base)) > - return PTR_ERR(core->base); > - > - return 0; > + return PTR_ERR_OR_ZERO(core->base); > } Thanks, but I don't usually want this kind of patches. They're mostly just extra changes, increasing the chance of conflicts, and, in my opinion, the current code is clearer than the proposed one. Tomi -- Texas Instruments Finland Oy, Porkkalankatu 22, 00180 Helsinki. Y-tunnus/Business ID: 0615521-4. Kotipaikka/Domicile: Helsinki