>> +++ b/drivers/s390/net/qeth_core_main.c >> @@ -5638,9 +5638,10 @@ static int qeth_core_set_online(struct ccwgroup_device *gdev) >> { >> struct qeth_card *card = dev_get_drvdata(&gdev->dev); >> int rc; >> - int def_discipline; >> >> if (!card->discipline) { >> + int def_discipline; >> + >> if (card->info.type == QETH_CARD_TYPE_IQD) >> def_discipline = QETH_DISCIPLINE_LAYER3; > > Same here: I don't think we want to start with patches like this. Thanks for your feedback. > This going to be a never ending story without much benefit. Is the source code a bit clearer and safer if it will be expressed directly that the use of a specific variable is not intended for a complete function implementation but for the smaller scope of an if branch? Regards, Markus -- To unsubscribe from this list: send the line "unsubscribe kernel-janitors" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html